MCE Text Editor

erik's Avatar

erik

01 May, 2014 08:20 PM

When trying to use bold or italic text in the text editor the system stalls and it is impossible to save.
I have deleted the gz file but it does not change anything.

http://support.berta.me/kb/faq/text-editor-doesnt-work

Does anybody have an Idea?

  1. Support Staff 1 Posted by Uldis on 02 May, 2014 07:14 AM

    Uldis's Avatar

    Hello,
    try the solution from this article http://support.berta.me/kb/faq/text-editor-doesnt-work

  2. 2 Posted by erik on 02 May, 2014 08:34 AM

    erik's Avatar

    I have tried to delete the gz file a few times and also tried this in relation to different browsers.
    Both Safari and Firefox but it still impossible to save with Bold text.

  3. Support Staff 3 Posted by Uldis on 02 May, 2014 10:13 AM

    Uldis's Avatar

    You have enabled PHP suhosin extension on your server which blocks posting HTML code.

    Ask your hosting provider to remove PHP suhosin extension from your websites configuration, or at least configure to disable it form engine part here - erikhagman.com/engine/

    Another solution is to host your website on our servers, read more about benefits here: http://support.berta.me/kb/faq/whats-the-difference-between-hosted-...

    Good luck

  4. Uldis closed this discussion on 02 May, 2014 10:13 AM.

  5. erik re-opened this discussion on 02 May, 2014 12:45 PM

  6. 4 Posted by erik on 02 May, 2014 12:45 PM

    erik's Avatar

    Hi!

    Thank you for your support in this issue it was not suhosin but a firewall that caused this. Now its working!

    Below the explanation from my host:

    That's good to hear! I'm just sorry for any trouble that it caused for you. It's similar, in that both are modules to aid in security, but they are not related.

    Suhosin sets limits on the data that can be input and output via PHP as well as blocks certain PHP functions that are generally not required on a shared hosting platform.

    mod_security on the other hand is a Web Application Firewall. Using regex matches amongst other things, it scans all web requests and blocks them if the request matches pre-defined rules. This is great for blocking SQL injections and preventing a lot security issues in out of date/unpatched software, however, sometimes it can throw up false positives and block legitimate requests due to the way that it matches, which is what was happening in this case.

    I have disabled the rules that were causing you a problem, so that should be the end of that. However if you do have any more issues, or would rather have mod_security turned off all together, just let me know.

    Regards,

    Steve
    LDHosting.com

    Erik Hagman
    [email blocked]
    http://www.erikhagman.com
     +46 (0) 721594649

  7. Support Staff 5 Posted by Uldis on 02 May, 2014 01:06 PM

    Uldis's Avatar

    Glad to hear it's solved,
    have a nice day

  8. Uldis closed this discussion on 02 May, 2014 01:06 PM.

  9. erik re-opened this discussion on 02 May, 2014 01:22 PM

  10. 6 Posted by erik on 02 May, 2014 01:22 PM

    erik's Avatar

    Im happy to.
    Thank you for a very neat system!

    /Erik

    Erik Hagman
    [email blocked]
    http://www.erikhagman.com
     +46 (0) 721594649

  11. Uldis closed this discussion on 02 May, 2014 01:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Nov, 2016 11:00 AM
23 Jun, 2016 03:23 AM
23 Jun, 2016 03:22 AM
20 Jun, 2016 08:02 AM
18 Aug, 2015 11:09 AM