Creating Lightbox with a thumbnail

k.wassink's Avatar

k.wassink

05 Jun, 2014 12:46 PM

Dear Berta support team,

http://dbkv-showcases.artez.nl/~K.Wassink/

I have been working on a showcase portfolio with Berta and I've run into a problem which could be solved previously by manually changing files, but now no longer. I want to create a blackbox with an entry but I want to have two different files for the thumbnail and the picture shown in the blackbox. In my particular example, I want to have hexagon shaped thumbnails that link to the fullsize pictures in a blackbox. This used to be able by changing the files in the storage file and replacing the blackbox picture with a fullsize one with the same name. But when I tried this today Berta also changed the thumbnail into the fullsize picture (the same size as the previous thumbnail). Is there a way to make this work? You can see my design on the link above.

Here you can see my idea and that I want to show fullsize pictures in a blackbox when you click on the thumbnails instead of the hexagon thumbnail in the blackbox which happends now.

Thank you for your time,

Kevin Wassink

  1. Support Staff 1 Posted by Uldis on 05 Jun, 2014 01:07 PM

    Uldis's Avatar

    Hi, Kevin
    normally your described procedure should work fine, if not, try to set gallery size to small or medium and try again.

    let me know the result.

  2. Uldis closed this discussion on 05 Jun, 2014 01:07 PM.

  3. k.wassink re-opened this discussion on 05 Jun, 2014 01:41 PM

  4. 2 Posted by k.wassink on 05 Jun, 2014 01:41 PM

    k.wassink's Avatar

    Dear Uldis,

    Thank you very much for the quick response! However, it seems that it's not working as intended.

    I uploaded the pictures as 'medium' and 'small', but the thumb looks different than the picture I uploaded.

    As in:

    I uploaded the hexagon icon and got a small version of the full picture.

    When I replace the file in Filezilla the pictures change quite erratically: it shows the hexagon in the gallery but displays a small version of the full picture on the site itself.

    I hope there is a quick solution for this and I thank you for your time!

    Kevin

  5. Support Staff 3 Posted by Uldis on 06 Jun, 2014 07:01 AM

    Uldis's Avatar

    This is because small, medium and large version of file generates on request - when gallery is generated - showed as slideshow.

    You need to:
    1) upload a hexagon
    2) close the image gallery manager by pressing on "x"
    3) after closing, new gallery are generated and all needed image sizes are created.
    4) only then you can replace the original file on server

    good luck

  6. Uldis closed this discussion on 06 Jun, 2014 07:01 AM.

  7. k.wassink re-opened this discussion on 06 Jun, 2014 09:17 AM

  8. 4 Posted by k.wassink on 06 Jun, 2014 09:17 AM

    k.wassink's Avatar

    Thank you for all your help so far! It worked in the end although it took some time to figure out. The file resolutions were smaller than the berta settings for image sizes, this way the thumbnail files were not generated in the storage file. When I changed the settings to be the same size or smaller it generated them.

    Which leads to a new problem of a different origin. Is there a way to change the resolutions in the source files, because I'm using a lot of different resolutions which would all be lost cause of the small, medium, large settings.

    I'm really thankful for all your help this far!

    Kevin

  9. Uldis closed this discussion on 09 Jun, 2014 06:28 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac